troubleshooting icon

Data importing & Excel errors

Map display:

Publishing and testing:

Other:

 

 

 

Maps​

Can I create my own maps?

Yes, that is possible, but custom maps need to be designed or modified using GIS software. From there, they would need to be exported in GeoJSON format for StatPlanet Cloud, or Shapefile format for StatPlanet. It is also possible to create multi-layer maps.

StatPlanet also supports custom designed maps built with Adobe Animate.

 

Where can I find free maps to use in StatPlanet?

Please see the free shapefile map downloads page to find shapefile maps which can be used in StatPlanet (Shapefile edition). It includes a list of country maps available for download, as well as links to websites where shapefiles can be freely downloaded. Please note that StatSilk currently does not provide any maps other than the USA state and world map (include with StatPlanet), and some country maps which are downloadable via the above link.
 

How do I add countries, regions, cities or other areas to my map?

See also: merging map areas to create a region

Cities, countries, regional aggregations, etc. can be added to StatPlanet in the form of "map points". Map points will not just appear in the map, but also in the graphs and in the map area Selection panel.

There are three ways in which map points can be added:

  1. If the map points are already in the shapefile map, you could use GIS software to convert points to polygons (since StatPlanet currently only supports polygons). Points converted to polygons can be converted into interactive map areas just like any other regions or areas of the interactive map areas.
  2. Using a list of latitude / longitude coordinates for each map point, the points can be automatically imported.
  3. Dragging and dropping map points into place within StatPlanet itself. This is sometimes the most efficient method if you have a smaller number of map points. This procedure is described below.

Procedure for adding map points through drag-and-drop:

  1. Open the StatPlanet Data Editor and in the worksheet "Import" go all the way to the last country or map region at the end of row 2.
  2. Insert the name(s) of your map point(s) in this row and press the button Save data. Data can be added in this column in the same way as with any other map area. You will need to add some data for this map point in order for it to appear in the map. (Note: once you have pressed Save data, the map point name should also have been added in the worksheet “Data”. If you cannot see the map point in StatPlanet, please check the worksheet “Data” to confirm it has also been added here).
  3. When you next open StatPlanet, one or more map points (in the form of a circle) will appear in the top left corner of the map, representing each of the new map areas added. Right click anywhere inside StatPlanet and in the popup select ‘Move text labels or map points’. Click on the map point and then click anywhere on the screen to move it to this new location. Similarly, the text label for a map point can be dragged and dropped to a new location.
  4. To copy the map point coordinates, right click again and select ‘copy map point coordinates’.
  5. Open the StatPlanet Data Editor and go the sheet ‘Settings’. Scroll down to ‘Special options’ and next to M-DOT-COORD paste the coordinates you just copied. In this section you can also set the size of the circle representing the map point. Click on Save Settings to save.
     

Can I have more than one map (for example, country and province levels)?

Yes, there are three approaches to achieving this:

  1. Set up two different versions of StatPlanet (in two separate folders), with different maps. Publish both online, and link from one map to the other. To set a link when clicking on a map area (for example, to link to a province map when clicking on a country map), see the User Guide, section "Map area popup text and links". 
  2. Create a multi-layer shapefile map (requires some familiarity with GIS software)
  3. If the second map consists of cities or other types of map points, they can be activated when zooming into a particular map area. To create such map points, please see the User Guide, section "Add map points", and to display them only for a particular province/region of the map, see the section "Custom ‘zoom-to’ map regions or groups". 

 

Merging map areas to create a region

Map areas can be merged and treated as a single region. This can be done using the StatPlanet Data Editor, as follows:
  1. In the sheet 'Import', replace the names of any map areas you wish to merge with the name of the merged region (in row 2). For example, to create the Benelux region in the 'World Map' edition, rename the countries Belgium, the Netherlands and Luxembourg to Benelux.
  2. Only one column should have data (otherwise the merged region will appear more than once in the Selection panel). For example, if creating the Benelux region, remove any data in the columns for the three countries, and insert Benelux data in just one of the columns (it can be any of the newly renamed Benelux columns).
In StatPlanet, the merged map areas will now be grouped together and treated as one. This can be done using any StatPlanet edition.
 
Please note though that if you merge map areas, it is no longer possible to display data for the individual map areas (only for the merged region). If you need to visualize data for both the region and the constituent map areas, you could use the following approach:
 
- Create a map point for the region, instead of merging the countries (as described above). The map point can be placed in the relevant area of the map, for example, adjacent to the map areas it represents.
- Merge the map areas, and then create map points to represent the individual map areas. For example, in the Benelux example above, you could create a map point for each of the three countries (Belgium, the Netherlands, and Luxembourg), and place them on top of the corresponding country. These map points would have an associated column in the StatPlanet Data Editor to display the country-level data.
 
If you need to display data for two overlapping regions (e.g. Benelux and Europe), the same applies as above. You could merge map areas to display the first region, and use a map point to display the second region. For example, in the Benelux example, you could merge the three countries to create the Benelux, and then use a map point to represent Europe. Alternatively, you could use map points for both regions (e.g. for both Europe and the Benelux).
 

Can do I export the maps/charts as a vector image?

Vector image export enables high-resolution images, suitable for publication. It also enable the images to be edited after export.
 
StatPlanet Cloud can export maps  graphs in the SVG format (Scalable Vector Graphics). SVG images are editable, and ideal for high quality print publications.
 
Maps/charts can also be exported as a vector image using StatPlanet and StatTrends, but it requires additional steps. Vector images can be exported, in PDF-format, as follows:
  1. Download the free pdf-creator software. It is recommended that you download version 0.9.3 (not the latest as it potentially installs toolbars unasked). Once this is installed, it should appear as a printer. Please note: StatSilk has no affiliation with pdf-creator so please install at your own risk.
  2. Open the desktop version of the software. You should see a file menu in the top of the window (if you are in full-screen mode, press the ESC keyboard button).
  3. PDFCreator exports the entire display within the application. You can use the 'view' (eye) icon in the bottom-left corner to hide any panels you do not wish to export. The map legend can be dragged and dropped to the required position prior to export if necessary.
  4. Select File -> Print, and as the printer select "PDFCreator". Then select 'preferences' and for the orientation choose 'landscape'. After clicking on 'print', the PDF will be generated and can be saved onto your PC. 

When opening the PDF file, you will notice you can zoom in to your map without loss of quality. Since PDFCreator by default prints to a standard A4 size page, you may need to either change the zoom level of the map or change the paper/output setting in order to ensure if fits on the page. The print paper/output setting is typically found under the 'advanced' options in the 'preferences' screen. You may also need to experiment with moving around the map or using the 'portrait' orientation to get the exact view you want in the exported PDF page.

Further editing

The map can further be edited using software such as Adobe Illustrator or the free and open source Inkscape software. 

StatPlanet runs in Flash-Player which means that all on-screen drawing is vector-based. Hence, not only maps but also graphs, charts and other interface elements can be exported in vector format through the method described above.
 
Since StatPlanet can be used to read shapefile maps, this method can be used to convert shapefile maps into various vector formats. For example, Inkscape can be used to convert the exported vector PDF into the SVG vector format, and Adobe Illustrator can convert the vector PDF into the AI or SWF vector formats. Once a shapefile map has been converted into vector format it can be imported into and edited using Adobe Flash Professional, to create customized maps for StatPlanet.
 

I am looking for a particular (shapefile) map, can StatSilk provide it for me?

StatPlanet comes with embedded versions of a world map (country boundaries) and a USA map (state boundaries). You can also download many country maps which have been set up to run through StatPlanet. For maps which are not in this list, please see downloading free shapefile maps, which includes a list of recommended websites for finding shapefile maps (please note that StatPlanet is required if you wish to use these to create interactive maps). A Google search for a particular map which includes the keywords 'shapefile map' or 'shp' (the filename extension) may also help you find what you are looking for.

 

How do I display only a specific continent or map region, excluding the rest of the map?

In StatPlanet it is possible to zoom into an area of the map on startup, for example 'Africa', and hide the rest of the map. First, you would need to set the startup map region through the StatPlanet Data Editor, as described in the User Guide (see Custom ‘zoom-to’ map regions in Chapter 6). The next step is to change the color for the following two variables in the StatPlanet Data Editor, sheet 'settings':
 
- MAP-NTRL - set to white, using color code: 0xFFFFFF
(map color of countries not in the current region)
 
- MAP-BRDR - set to white, using color code: 0xFFFFFF
(map border color)
 
This makes both the surrounding map areas, as well as the borders, white. Assuming the background color is white, they will appear to be invisible. If you are using a different map background color, the colors for the variables above need to be changed accordingly.
 
StatPlanet uses Hex color codes. One of the many online colorpickers can be used to find a suitable color. Please note that it needs to be in the form "0x" followed by the Hex code (so #FFFFFF for example would become 0xFFFFFF).

 

Can I display multiple interactive maps on one page?

Multiple maps can be displayed on one page by setting the "base url" (location) for each of the maps within the web-page code. Each map requires a separate folder on the website server containing the files for that map (those from the 'web' sub-folder).
 
The following page has a multiple maps demo and source code.

 

What type of map legend classification method does StatPlanet use?

StatPlanet uses a combination of the equal interval and quantile classification methods. The equal interval method divides the map legend value range into equal-sized subranges. But first, StatPlanet does a percentile analysis to determine where to set the equal interval values to ensure a more even distribution of values in each color class.
 
StatPlanet does not use a pure quantile classification, because this would lead to non-equal intervals. With non-equal intervals, different map colors reflect (potentially very) different map ranges, which can be misleading when interpreting the map.
 
 

 

Da​ta

Is there support for XML or JSON?

StatPlanet Cloud will have JSON support (expected in version 1.2).

For an example implementation, with data loaded dynamically from the World Bank API, see StatPlanet World Bank

XML is not supported because it inflates the file size. For large amounts of data, CSV or TXT are often the better choice because the file sizes are much smaller. For a given data set, XML files are often between 5 and 15 times larger than the equivalent amount of data stored as a CSV file. For small data files (e.g. 20 kb) this is not a big issue, but for larger files (e.g. 1000 kb), the difference in download time could be minutes rather than seconds. StatPlanet has support for ZIP compression, which can further reduce the file size.

Data stored in the XML format is much larger because each data element needs to be described or 'tagged'. This requires many characters - often more characters than the data element itself. For example, each data element may be described as follows (in this example, assigning the value of 21.5 to a specific indicator, country and year):

<data>
<indicator>AGR.PL</indicator>
<country>AFG</country>
<year>2000</year>
<value>21.5</value>
</data>

In a CSV file, the country, indicator and year only need to be indicated once for a set of data elements. The data elements themselves are seperated with a comma.
 

What kind of data can be imported into StatPlanet?

Any format readable by Excel can be imported, such as XLS, XLSX, CSV, TXT and HTML. The import macro will automatically recognize the structure of your data file and switch columns to rows or vice versa if necessary.

StatPlanet can be used to automatically import country-based data from a wide variety of data sources. The data editor can recognizes commonly used spellings of country names. You can also easily add new spellings to the list of recognized country names in the data editor.

StatTrends can be used to automatically import any kind of data. Once you have added your data headers / variables in the data editor, it can automatically import data by looking for these headers / variables in the data file. 
 

How do I import different kinds of date/time-based formats, such as months or quarters?

StatPlanet and StatTrends support any kind of date or time format. However, the import macro currently only recognizes years (e.g. in the format "2010", "2011" etc.). To import data which uses a different date or time-based format such as months, data needs to be imported one date-unit at a time, or through the following workaround (which is more efficient):

1. In your data file, replace your date or time-units with years temporarily, just to import them in the correct order (for example, January - December could be replaced with 2001 - 2012)
2. Once the data has been imported, change the years back to their original date or time-units.
 
Data can also be copied manually without using the import macro. Please see the "data file structure" section of the Quick Start guide for more details on how to structure your data manually.
 

How do I import large data sets (multiple categories of data)?

Data can be imported from all Excel sheets in the selected file. Each sheet is imported as a separate category, and the sheet name becomes the category name. Therefore, the best way to organize your data file would be to split the sheets according to the categories you would like to create within StatPlanet/StatTrends. Each sheet (category) can have multiple indicators and time periods. Please download the example spreadsheet for an example (with country-level data).

In order to disable importing all sheets, go to the sheet 'Import names' and set 'Import all sheets' to FALSE. When set to FALSE, it only imports the currently selected sheet when the file is opened. 

 
If your data set contains other date formats such as quarters or months, please see the date format instructions.
 
For more information about the data structure, see also the Quick Start Developer Guide.
 

How do I d​isplay percentages?

StatPlanet and StatTrends do not support the 'percentage' format in Excel. Therefore, to display percentages, you would need to save numbers in the regular number format rather than the Excel percentage format. An easy way to convert a number formatted as percentage to a regular number in the StatPlanet Data Editor is as follows:

  1. Select the numbers you wish to convert.
  2. Right-click and select 'Format Cells'.
  3. Select the 'General' format or alternatively the 'Number' format and click OK (the display of numbers will change from e.g. 1% to 0.01).
  4. In an empty cell, insert the number '100'. Then copy this cell.
  5. Select the numbers you wish to convert and click on 'Paste Special'. Then select 'Multiply'. This will multiply all the numbers by 100.
  6. Remove the cell with the number '100'.
  7. For the indicator(s) which display percentages, go to the 'UNIT' column and insert the symbol: %

 

Installation & system ​requirements

What is the process for receiving a licensed version once payment has been made?

Once payment has been made you will receive a receipt confirmation. Within 24 hours, a download link to the licensed version of the software will be provided, including further instructions.

Updating to the licensed version can be done as follows:

Web version

  • If you have previously downloaded the software and wish to continue with that version, you will only need to replace the file 'content.swf' in your existing StatPlanet or StatTrends folder. The licensed 'content.swf' file will be provided in the e-mail. It will need to replace the file 'content.swf' in the sub-folder 'web' in your existing StatPlanet/StatTrends folder.
     
  • If you have not yet started using the software, you can download the licensed software package, and follow the getting started guide.

Desktop version

  • If you have previously downloaded the software and wish to continue with that version, you will still need to download the software package. Then, locate the file 'StatPlanet.exe' or 'StatTrends.exe', and copy it to your existing StatPlanet or StatTrends folder, replacing the original file.
     
  • If you have not yet started using the software, you can download the licensed software package, and follow the getting started guide.

 

 

Which hardware / software is required to run StatSilk software?

User hardware / software requirements

StatSilk software requires no installation. Moreover, no additional software is needed to run the offline version, but the online version requires the Adobe Flash Player (version 9 or above). Flash Player is already installed on about 99 percent of Internet-enabled computers. To add your own data, Microsoft Excel is required for automatic importing of data, but any spreadsheet software can be used to add data manually.

A modern PC is not required to run StatPlanet or StatTrends. For a Windows PC, the minimum requirement is an Intel® Pentium® II 450MHz processor with 128 MB of RAM. The web-based version of StatPlanet requires the Adobe Flash Player (version 9) to run, which supports Windows, Macintosh and Linux platforms.

For mobile devices, StatPlanet Cloud is recommended. However, StatPlanet and StatTrends can run on most recent Android-based mobile phones and tablets.

You can also use the Adobe Flash Player system requirements as a guideline.

Server hardware / software requirements

There are no specific server requirements to run StatSilk software. However, StatPlanet and StatTrends require either PHP or ASP support for exporting maps, graphs and data.

StatPlanet Cloud as the name specifies is cloud-based and only maps and data files need to be hosted on your server. There are no additional server requirements for export functionality.

StatPlanet and StatTrends are very lightweight - only 300-500 kb. A dedicated server is generally not required for normal usage (< 5000 visitors/users a day). See also:

 

How to run StatSilk software on a Mac

StatPlanet Cloud runs on both Mac and Windows.

A Mac version is available for download for StatPlanet. Data can be imported using Excel for Mac. However, not all versions of Excel for Mac have support for macros which are required to automatically import data. Macros are supported in Excel 2004 for Mac and again since Excel 2011. If macros are not supported, data can still be inserted manually as described in the Developer's Guide. Please note that the data.csv file needs to be saved as a "Windows Comma Separated (.csv)". Feel free to download and try out StatPlanet for Mac, which has a free desktop version for non-commercial use or for testing purposes.

 

How to run StatSilk software on mobile devices or tablets (e.g. Android or iOS)?

StatPlanet Cloud runs on all smartphones and tablets including iOS and Android devices.

If you wish to run StatPlanet or StatTrends on an iOS devices, there are several third-party apps which can be used to do so. Please note that we do not endorse any particular app, so please purchase/install the app at your own risk. StatSilk has been tested - and successfully run - using both the free Puffin Web Browser and the non-free Photon Flash Player for iPad and iPhone. For Android devices, Flash can be installed manually.

 

Is there a mobile app?

A custom app can be developed for you. Please contact us for further information and to request a quote.

 

How do I update (upgrade) to the latest version?

Updating to the latest version while keeping your data and settings can be done by following these steps:
  1. Make a copy of your original StatPlanet Data Editor (i.e. edit->copy, edit->paste in the same folder to get the filename 'StatPlanet Data Editor copy'). 
  2. Download the latest version of the software and extract the files onto your computer. 
  3. Go to the folder matching the version you are updating (i.e. if you are updating StatPlanet USA, open the USA folder). Open the StatPlanet Data Editor, and select the sheet 'Tools' in the bottom-right corner.
  4. Ensure that macros are enabled and click the button 'Copy data & settings into this file'.
  5. Select the file 'StatPlanet Data Editor copy' (from which you wish to copy over the data and/or settings) and follow the on-screen instructions.
 
Can I run / use /manage multiple instances of StatPlanet / StatTrends on one computer?
 
You can manage as many instances of StatPlanet / StatTrends as you like, with different maps / data sets. The software requires no installation so you can simply make a copy of the entire StatPlanet or StatTrends folder, and place it in a location where you have permission to save files (for example, in your "documents" folder). You can also freely rename the different StatPlanet / StatTrends folders, as long as the filenames are unchanged, and the sub-folder names ('web' and 'export') also need to remain unchanged. Multiple instances of the StatPlanet and StatTrends applications can also be run at the same time. It is not possible, however, to open multiple instances of the StatPlanet Data Editor at the same time, as Excel does not allow two files to be open with the same filename.
 
 
Can I integrate StatPlanet / StatTrends in PowerPoint?

StatPlanet and StatTrends are particularly suitable for use during presentations. Although you could of course give the entire presentation using only StatPlanet / StatTrends, you way wish to integrate it as part of a PowerPoint. The software cannot be embedded in PowerPoint, but there are two approaches to creating a seamless transition:

  1. Create an object (e.g. textbox, button, shape) and then create a link to StatPlanet/StatTrends from that object, as follows:
    • Important note: If the presentation will be run from another computer, first make sure that StatPlanet or StatTrends is in the same folder as your presentation (e.g. in a sub-folder 'StatPlanet). This will ensure that PowerPoint creates a "relative" hyperlink to the application, which enables it to find the application no matter which computer/location the files are in.
    • Go to the 'INSERT' tab and select the icon 'Hyperlink'.
    • Navigate the folder containing StatPlanet/StatTrends, and select the file "StatPlanet.exe" or "StatTrends.exe".
    • For more information, see also Start a program during your presentation.
  2. Open up StatPlanet or StatTrends just before launching your presentation, go back to your presentation, and when the time comes to switch to StatPlanet / StatTrends press ALT+TAB on your keyboard. This will cause it to seemlessly switch to StatPlanet / StatTrends.
In the StatPlanet Data Editor sheet 'settings', there is a variable to set the offline version to open up fullscreen: FULLSCR (set to TRUE).

 

Langu​age

In what languages is StatPlanet available?

StatPlanet is available in the following languages:

  • Bahasa Indonesia (courtesy of the Government of Indonesia)
  • Danish (courtesy of Peter Erbs-Maibing, Research Centre for Prevention and Health, Denmark)
  • Dutch
  • English
  • French
  • German
  • Greek
  • Portuguese Brazilian (courtesy of the Instituto Centro de Vida)
  • Russian (courtesy of Andrey Loschilov)
  • Spanish
  • Turkish (courtesy of Emre Koyuncu and Kutad Alpturkan) - as of v 3.1
  • Vietnamese - as of v 3.3

These translations are included in the StatPlanet Data Editor. Please see the User Guide for information on switching language and modifying or adding a translation.
 

Can I display characters using an alphabet other than Latin/Roman?

Yes, the licensed versions of all StatSilk products supports non-Latin international character sets. Please note that right-to-left fonts (e.g. Arabic and Hebrew) are only supported by StatPlanet Cloud.

To use non-Latin character sets in StatPlanet or StatTrends, please follow these steps:

1. Remove the files "data.csv" and "settings.csv" in the main directory and also in the directory 'web'.

2. In the StatPlanet Data Editor, go to the sheet "Settings". Under Startup options - Data format, select: TXT (tab-separated values). Then click on “Save settings”.

3. The international character sets can now be used in the desktop version of StatPlanet. The web version does not include the international character set by default. This is only available in the purchased/licensed version on request.

 

Can I change the font or text size?

The font sizes can be changed in the StatPlanet Data Editor sheet 'settings', variables MAP-TXT-S and MAP-TXT-S2 (for map text size), FONT-S (for general interface text size) and FONT-P-S (for popup text size).

It is not possible to change the font, which is Arial, because it is embedded in StatPlanet / StatTrends. However, when purchasing the licensed version it is possible to request the font to be changed. Please note though that this would be a permanent change in the licensed version.

It is also possible to change the font of popup text on the map, since it accepts text in html format. Therefore, the font can be set using HTML formatting.

 

Publishing online​

Can I publish the software using Google Sites?

Yes you can use Google Sites to host StatSilk software for free. For StatPlanet Cloud, see the included user guide for online publishing instructions.

For StatPlanet / StatTrends, the steps are as follows:

  1. Create a site.
  2. Select the 'gear' icon in the top-right corner (Open More Actions menu).
  3. Select 'manage site'.
  4. Click on 'Attachments' in the menu on the left.
  5. Select 'Upload' and then upload all the files in the StatPlanet or StatTrends 'web' directory.
  6. Run StatPlanet through the StatPlanet.swf in the location it was uploaded, for example: https://sites.google.com/site/statplanettest/StatPlanet.swf (where sites.google.com/site/statplanettest/ is the location of your Google site).
  7. Note for the ESRI shapefile map version: this requires an extra step. To include the map files, a webpage called 'map' needs to be created. The map files in the map folder (map.dbf and map.shp) need to be uploaded as attachments, as described above.

 

Can I publish the software using Wix?

Publishing using Wix is not recommended, as Wix does not allow most types of external files (such as map files, or any type of data files besides .xls and .xlsx). This makes it difficult to host StatPlanet.

See also Google Sites for a free alternative.
 

What are the bandwidth requirements?

StatPlanet Cloud only requires data and map files to be hosted (which are typically less than 500 kb combined).

The web-versions of StatPlanet and StatTrends are very lightweight (less than 700 kb). Including map and data files, the typical size is around 1 mb.

If data files are very large, they can be split into multiple data files which are loaded on demand - i.e. only when the user specifically makes a requests to view that data set.

 

Is the information used in the software secure?

None of the StatSilk software shares or uploads any data or information, the exception being Google Analytics data (and only if an optional add-on module is enabled). To further ensure the security of data when published online, a data encryption module is available for StatPlanet and StatTrends.
 
StatPlanet Cloud as the name indicates is hosted in the cloud, but this is only the case for application files. Maps and data files can be stored in any (secure) location, and none of this information is sent to the cloud. The application files are downloaded from the cloud to the users' computer. At the user-end, the three components come together in the web-browser: the application files, the map file and the data files, to create the visualizations. This happens on the users' computer, so none of this process takes place on a web server or 'in the cloud'.
 
The free Microsoft tool TCPView can be used to evaluate and verify which data transfers are occurring when using a web application such as StatPlanet Cloud.
 

Can I publish the software using DropBox?

Update: For DropBox accounts created after October 4, 2012, the public folder option is no longer available in free accounts. See also Google Sites for a free alternative.

Yes, through the public folder feature. If you do not have a public folder, please see 'Creating a public folder' on this page. Then use the 'copy public link' feature to get the web-link to the file 'StatPlanet.html'. You can find this option either by right-clicking on the file in the public folder within the DropBox website, or on your PC, right-clicking and choosing Dropbox -> Copy public link.
 

How do I publish the software online?

For StatPlanet Cloud, see the included user guide for online publishing instructions.

StatPlanet and StatTrends can be published in a website (including a CMS-based website) through the following steps:

  1. Locate the 'web' sub-folder in the StatPlanet (or StatTrends) folder you are using.
  2. Upload all the files and folders inside the sub-folder 'web' to a designated area on the website where you normally put external files and images. For example, in the directory mywebsite.com/files. Create a sub-folder (e.g. 'statplanet') and place the files here. If you are using the 'Shapefile' edition of StatPlanet, please see also the following troubleshooting section to ensure the map files can be found by StatPlanet.
  3. You can then link to the ".html" file where you uploaded the StatPlanet / StatTrends files, for example: http://www.mywebsite.com/files/statplanet/StatPlanet.html. Feel free to rename this file. 

For embedding the software within a CMS, please see the section below.

 

How do I publish the software in a CMS (Content Management System)?

If you wish to embed StatPlanet or StatTrends within a web-page in your CMS, the solution depends on the CMS you are using. The steps for embedding it in two of the most popular CMS's - Drupal and WordPress - are provided below. See also: Embedding Flash files into SharePoint

If you are not using Drupal or WordPress, the following are general instructions which should work with most CMS's as long as they provide an option of editing the HTML code of a web-page:

  1. After completing the steps above, create a new page in your CMS in which you would like to embed StatPlanet/StatTrends.
  2. Go to the 'edit HTML' screen of the page, and specify the location of the StatPlanet / StatTrends files using the 'base' HTML tag. To do so, the following line of HTML code would need to be placed anywhere between the <head> and </head> tags. The text '/files/statplanet/' in the code below needs to be replaced with the actual location of the files on your server (from Step 2 above):
                <base href="/files/statplanet/" />
 
See also: using the "base" tag for more details. The CMS you are using may also have specific instructions in the documentation for using the 'base' HTML tag.
  1. Embed the file 'StatPlanet.swf' (for StatPlanet) or 'StatTrends.swf' Flash file for (StatTrends) in the web-page. The method of doing so depends on the CMS. 
If you run into any difficulties, you can post your support question on the Forum
 

Embedding the software within DRUPAL:

Drupal 5/6

  1. Download and install the Drupal module Flash Node
  2. The option to add a Flash Node should now appear in your website menu. So add a Flash Node
  3. Where it asks you to 'Choose File', select the StatPlanet.swf file (which is the loader)
  4. In the Basic flash node options, insert the Width and Height (e.g. width 765 / height 567).
  5. In the Advanced flash node options, under Base, insert the location where you placed the StatPlanet files as described above. For example: /files/statplanet
    (no need to put the full path)
  6. In Body, you can add text / images / contents as with any other Drupal page.
  7. Click on Submit.
     

Drupal 7

  1. Download and install the modules and CKEditor and CKEditor SWF (support for "CKEditor SWF module" would need to be enabled in the CKeditor Plugins settings).
  2. Add a basic page or other kind of content, and in the CKEditor click on the red 'Flash' icon.
  3. Below 'URL', insert the location where you placed the files as described above, followed by 'StatPlanet.swf'. For example: /files/statplanet/StatPlanet.swf
  4. Insert the Width and Height according to preference (e.g. width 765 / height 567).
  5. Select the Properties tab, and below 'Base' insert the location where you placed the files. For example: /files/statplanet. If you do not see the 'Base' option, make sure that the 'Text format' (shown below the body/contents area) is set to 'Full HTML'.
  6. Click on OK and save the page.

Embedding the software within WORDPRESS

*Please note: The required Flash plug-in is not supported if you are using the free Wordpress.com platform, i.e. if you set up your website on the Wordpress.com website. To follow the steps below, you would need to host the Wordpress platform on your own web server.

  1. Install the WordPress plugin Kimili Flash Embed. Important Update: As of the WordPress 4.0.1 update from Nov 20, 2014, Kimili Flash Embed plugin version 2.5.1 (or higher) is required, which is compatible with the new version of WordPress.
  2. Place the Statplanet data and flash files into a directory underneath wp-content/uploads, e.g. 

    wp-content/uploads/statplanet

  3. In the header.php file, place a base tag within the <head></head> tags, with the full path pointing to the directory where your files are stored. This needs to be made conditional so that it is only inserted on pages with StatPlanet embedded. In the following example, you would need to replace page ID "1" (indicated through "is_page(ID)") with the WordPress page ID number of your page:
    <?php
    if (is_page(1))
    echo '<base href="/wp-content/uploads/statplanet/">;
    ?>
     
    And for a second map, you can specify another file location as follows (replacing page ID "2" with the WordPress page ID number of your page):
     
    <?php
    if (is_page(2))
    echo '<base href="/wp-content/uploads/statplanetcounty/">;
    ?>
     
    Alternatively, the page title could be used, for example:
     
    if ($page_title == 'my page title')
     
    See also this Forum post for more details.
     
  4. Go into the post or page where you want to embed statplanet, click on the HTML tab and you will see a button Kimili Flash embed. Insert the filename of the flash file e.g. StatPlanet.swf and then publish.

Troubleshooti​ng

In the StatPlanet Data Editor I get an error message when pressing the 'Save' button

Update for Excel 2010 - It appears that Skype (or possibly other applications) can cause an error in Excel 2010 which prevents the 'paste' functionality from working properly. This will cause an error when pressing the 'Save button'. For more information please see the Microsoft Support forum.

If you get an error message when you press 'Save' in the StatPlanet Data Editor, please check the following:

- Have you unzipped / extracted the files? You will get this error message if you have opened the Data Editor without extracting the StatPlanet directories and files onto your computer.

- Make sure that the file 'data.csv' is not open when you press the 'Save' button.

- Make sure you have not renamed any of the Excel sheets in the StatPlanet Data Editor, nor any of the original filenames and directories.

- Make sure the files are copied (extracted) to a place where you have permission to save data. If you copied the software into the 'Program Files' directory you may get a VB runtime error 1004. Copying it to your 'Documents' folder, or the desktop (for example) would resolve this issue.
 

The shapefile map does not load

The shapefile map may not load for various reasons:

- Map ID error: The DBF file (map.dbf) uses an ID containing special characters which are not supported. It needs to have an ID which is alphabetical (a-z or A-Z), numerical or alphanumeric. The solution is to create one yourself by editing the DBF file. As of Excel 2007, DBF support is no longer included, but Open Office Calc can be used as a free DBF file editor.

- Time-out error: The shapefile is too large leading to a time-out error. This might be an issue if your shapefile is over 10 mb and/or contains a large number of regions. See how to reduce the size of a map for significantly reducing the map size.

- Unknown shapetype error:

  • The easiest is to use MapShaper. Open the Shapefile, and then export it as GeoJSON. Reload MapShaper and open the GeoJSON file you just exported. Then export as Shapefile. Now it should be in the right format. At the same time, you can also use MapShaper to reduce the map size.
  • Alternative: Use the free Quantum GIS software to open the shapefile (Layer -> Add Vector Layer -> Browse). Simplify the map if required (to reduce the file size). Then save the shapefile through (Layer -> Save As). If it still does not work, you may need to save it as WGS 84 (Coordinate reference system).

- Other: If none of the above apply, there may be a problem with the shapefile itself. Most commonly, the number of map areas in the DBF file do not match the map areas in the shapefile (SHP) itself. StatPlanet is sensitive to such issues, so even though it may open successfully in a GIS application, it cannot be read by StatPlanet. Specialized GIS software may be needed to resolve such errors.
 

The shapefile map appears blocky (the borders are not smooth)

This issue can be resolved by replacing the file 'SHPreader.swf' with 'SHPreader2.swf' included with the shapefile version of StatPlanet. You may first wish to make a copy of the file 'SHPreader.swf', then remove the original 'SHPreader.swf' and rename the file 'SHPreader2.swf' to 'SHPreader.swf'. For the web-version, you would need to copy the 'SHPreader.swf' file also into the 'web' directory.

 

Some map regions appear as circles (Shapefile Map edition)

If one or more circles appear in your map representing map regions, it indicates that these map regions were not found in the shapefile. This is likely to be related to the ID column which was selected when running 'setup shapefile map' in the StatPlanet Data Editor. In this case, you would need to run 'setup shapefile map' again. This time select a different ID column. You may need to experiment with different ID columns until you find that all map regions are displayed and there are no more map circles. If this does not resolve the issue, there may be a fundamental problem with the shapefile map and/or the 'dbf' file which defines the map regions in the map.

 

Trouble shooting data import issues

The following is a checklist of potential issues when data import fails. Please see also the example data file structured for import, or the Forum for technical support if you are unable to resolve it.

1. Spelling of names: If the spelling of a map area (or variable name) in the file you are importing is not recognized, the corresponding data will not be imported. The names in the data file need to match those in the StatPlanet Data Editor sheet "Import names". Please see “Names not recognized” in the User Guide for resolving this problem.

2. Numbers in names: If the names in your data file contain numbers in the same cell (e.g. "1 Alabama", "2 Alaska", "3 Arizona"), they need to be automatically removed as follows: (i) In the StatPlanet Data Editor, go to the sheet 'Import names', (ii) Select the checkbox 'Remove numbers / footnotes from names', (iii) Go to the sheet 'Import' and retry the import.
 
3. Names appear more than once: If the same map area or variable name appears more than once in your data file, the import macro will only import the data associated with the first one. To resolve this issue, please see "Names appear more than once" in the User Guide for resolving this problem. The Excel-based data restructuring tool may help you automatically structure the data for import, if you can organize the data as in the example set.
 
4. No year found in the data file / importing other kinds of date/time-based formats
 
Please see the example data file structured for import to see how to structure data with multiple years and/or indicators, so that it can be imported successfully. If you are not importing by year but another time format such as months, please see importing other data formats.

 

I get an error message when opening StatPlanet / StatTrends

The most likely issue is that there is a problem in reading the data structure. Errors in the data structure can generally be avoided by using the Import macro in the StatPlanet Data Editor. To check whether the data structure is correct, please see: data file structure. If you are editing the data.csv file directly on a Mac, please note that the data.csv file needs to be saved as a "Windows Comma Separated (.csv)".
 

StatPlanet / StatTrends does not run offline in the browser

If StatPlanet / StatTrends runs in the desktop version, but not offline in the web browser, you may need to change your security settings for Flash Player (Windows only):

1. Open the Control Panel (in the Start Menu, type 'control panel' in the search box)
2. Search for 'Flash' in the search input (top-right corner)
3. Select 'Flash Player'
4. Open the 'Advanced' tab
5. Select 'Trusted Location Settings'
6. Click on 'Add' and select the location of your StatPlanet or StatTrends folder

 

StatPlanet stops working once it has been published online

Shapefile version: map related issue

If you are using the 'shapefile version' of StatPlanet, the most common cause is that StatPlanet is unable to access the files map/map.dbf and map/map.shp. To verify if this is the case, try opening the following page in your web-browser:

www.mywebsite.com/statplanet-location/map/map.dbf (replacing the first part of the link with the location of StatPlanet on your website).

If you get a 'page not found' error, it could one or more of the following issues:

1. The map directory has not been copied to your web-server. Please also verify that the map filenames are all lowercase (i.e. "map.dbf" and "map.shp").

2. Access permissions for the directory 'map' and/or the files 'map.dbf' and 'map.shp' are currently restricted. This can be resolved by navigating to the map folder through FTP and right-clicking on the folder/files and enabling access. "Public permissions" - "Read" - needs to be enabled for the files map.dbf and map.shp. Alternatively, you could place the map files ('map.dbf' and 'map.shp') in the same folder as the other files, i.e. the files in the folder 'web'. For this to work, you would need to replace the StatPlanet.swf and SHPreader.swf files with these ones.

3. The server configuration settings allow only certain types of extensions to be loaded. If there are security measures permitting only files with specific types of extensions, the .shp and .dbf extensions would need to be added to this list. The .shp and .dbf extensions may need to be added to the server’s known mime types as an application/octet-stream. 

StatPlanet files cannot be found, freezing on the loading screen

If it freezes on the loading screen, it could be that the StatPlanet files cannot be located (which could be the case when for example hosting StatPlanet within a CMS or SharePoint environment). The location of the StatPlanet files on the server can be specified in two ways. The first is to use the "base" tag in html (see also using the base tag), e.g.
 
<base href="/files/statplanet/" />
 
Alternatively, you can specify the location ("base") within the javascript code included with StatPlanet in the file "StatPlanet_options.html". It can be specified as follows amongst the other 'params' code, for example in the row above 'params.quality = "high";':
 
params.base="/files/statplanet/";
 
The text '/uploads/statplanet' would need to be replaced with the directory on your web server where the StatPlanet files are actually located.

Web-server issue in loading the data.csv file

If none of the above work, the web server may be unable to load the data.csv file. If this is the case, the solution would be to:

(i) Zip the data.csv file, creating a zip file called data.zip which contains the file data.csv
(ii) Upload the file data.zip to the web server into the same directory as the data.csv file

StatPlanet will automatically read data from the data.zip file, which may resolve the issue.
 

The map points / text labels / mouse-over popups display the wrong label or data

This might happen if there is a column shift, which occurs when a column for a particular map area is removed in one sheet but not in another.

There are three sheets which need to be synced with each other: Import,  Import names, and Data. The map area names in the row at the top of these sheets need to be in the same order (see the example below). To see if they are not synced or matched, you could copy the row at the top of the of these sheets - containing the map area names - into a new spreadsheet. The map area names row from the three sheets (Import, Import names and Data) need to be placed one directly below the other. Then you can check if the names match across the columns. If there are column shifts, you would need to re-arrange, add or remove columns in the three sheets so that they are in the same order. If may then be necessary to re-import the data, if the data was imported into the wrong columns.

An example of a column shift is shown below. In this example, the sheets "Import names" and "Data" are synced (correctly ordered), but the sheet "Import" is not. Please note that the sheet "Data" normally shows the code for the map areas (as in this example) rather than the full name. In this case AFG is the code for Afghanistan, ALB for Albania and DZA for Algeria.

  column M column N column O
Sheet "Import" Albania Algeria Andorra
Sheet "Import names" Afghanistan Albania Algeria
Sheet "Data" AFG ALB DZA

In the case of map points and labels, if the above does not fix the issue, it means the map point and/or label is incorrectly placed. You would therefore need to move the map point and/or label to the correct location as described in the user guide. 
 

The map/graph/data export is not working

(Web versions of StatPlanet and StatTrends only).

If you get an error message when clicking export, or you see a text starting with '<?php' - this means that PHP is not supported by the web server, or is deactivated for the folder where the application is located.

A .htaccess file might be blocking the PHP script from running through the line 'php_flag engine off'. This rule needs to be disabled for the export sub-folder for the PHP scripts to run.

If the web server does not support PHP, there is an ASP alternative. You would need to update the StatPlanet Data Editor: go to the sheet 'settings', find the variable 'EXPLANG' and change 'php' to 'asp'.
 
It may also require some reconfiguration in the server settings to be done by the web manager to enable support for PHP or ASP.
 
StatPlanet Cloud does not require PHP or ASP to export maps and charts.
 
 

Purchasing, usage & distribution

What are the differences between the web version and the desktop version?

The web and desktop versions of StatPlanet and StatTrends are identical, except for the following:

  1. The web version is restricted for use on a particular web domain.
  2. The web version loads a company logo from an external file, whereas in the desktop version the image is embedded within the software.
  3. The web version is intended for use by visitors to the website; the desktop version is intended for internal, company use only. If the desktop version is required for other purposes, please contact us.

In terms of the license, the desktop version is free for non-commercial use, and requires a license for commercial use. The web version requires a license for both non-commercial and commercial use.

With the web license, all 'development side' aspects can still be done on the desktop, such as importing maps, importing data and customizing the software. The distinction between the two is only in terms of the end-user. If users access the software on the web, then the web license is needed. If users need to be able to work with the software on their desktop, then the desktop license is (also) required.
 

Can I purchase the software through a reseller?

Yes you can. We work with various resellers and are also happy to work with the reseller of your choice. When purchasing through a reseller, it would be helpful to specify the requirements as indicated in the purchase form.

 

Can I distribute the software on a CD and/or give a copy to others?

StatPlanet and StatTrends can be freely downloaded, copied and distributed to others via any medium (such as a CD or USB Flash drive) without requiring permission.

However, please include a reference to statsilk.com if it is used in a website, CD-ROM or publication.

See also the license terms.
 

Is the source code available?

The software is not completely open source and the code cannot be purchased. However, the following components are open source and can be modified:
 
- Some of the JavaScript libraries used by StatPlanet Cloud are open source.
- The StatPlanet Data Editor is open source. It is used to automate the process of importing data, save the data file and save the settings file in a format which can be read by StatPlanet. It can therefore be modified to better suit the format and structure of your data when importing.
- The Flash template in the 'custom Flash map' version of StatPlanet can be edited. It can be used to create your own map designs, as well as add any other features, design elements and text you may wish to include in your maps.
- The 'shapefile' code is open source and can therefore be modified and extended. This code is used to draw the shapefile maps.
A Splash Screen module is available for StatPlanet and StatTrends, to customize the opening screen.
 
For other types of modifications, please contact us
 

 

 

USER LOGIN