9 posts / 0 new
Last post
Map and data not loading with files house on Wordpress install

Using a Wordpress install not Wordpress.com. Have put StatPlanet files here:
<URL removed>
When I test this page:
<URL removed>

StatPlanet logo and progress counter load, but map and data do not.
I have followed instructions and troublshooting here:
Map works fine on local system. Thoughts on what I am doing incorrectly?

StatSilk's picture


When downloading the files from your WordPress site, they don't work offline either. The data.csv and settings.csv files seem to have become corrupted or otherwise were somehow not saved correctly. You could try uploading them again.

Since it works locally for you, it seems something went wrong when uploading it to the server. However, if re-uploading does not work, would you be able to indicate whether you edited these files directly, or using the StatPlanet Data Editor. And if the latter, which operating system / version of Excel are you using?



I used the StatPlanet Data Editor to make changes and am using Excel 2010 on a Windows platform. And reloading the data files. I have also dowloaded both the data.csv and settings.csv from the web and both open fine and data looks OK.

I have also tried uploading the files outside of Wordpress keeping all files that came with the package. That test is here and still same result:

Thanks for your assistance here.

StatSilk's picture


There definitely seems to be an issue with the data.csv and settings.csv files in how they are saved. I checked the files on http://www.civicyouth.org/ and found the same issue. If you open them in Excel you won't notice anything different. However, open them in Notepad, and you will find that the line breaks are missing (i.e. the lines are continues instead of split into rows). I don't know what could be causing this. If you click on 'Save data' in the StatPlanet Data Editor, it should normally save them correctly. I was wondering if you could check this yourself. If you click 'save data', and check the resulting files in Notepad, and see if the breaks are missing. If they are missing, the settings.csv file looks like this:

MAP,,,,,,,,,,,,,,,,,,,,All regions,1970,1190,95,,,,,,,,,,,,,,, etc

If they are saved correctly, the settings.csv file should look like this: (i.e., "Map", "All regions" and "Northeast" should all be on separate lines)

All regions,1970,1190,95,,,,,,,,,,,,,,,,,


So Frank this indeed does seem to be the problem. When i save the files using the data editor and then look at the data.csv and settings.csv locally they look fine. The line breaks are there. But when I FTP the files to our website and then download those files, the line breaks have disappeared.

I"ll do some research on this issue, but if you have ideas I'd love to hear them. I really appreciate your help here.

I used a different FTP program and that seems to have solved this problem. Thanks.

StatSilk's picture

Glad to hear that resolved it, I didn't know this could be caused by the FTP program. Would you by any chance be able to indicate the name of the FTP program you were using which caused this?

I was using a program called Core FTP - http://www.coreftp.com/

StatSilk's picture

Thanks for letting me know.