2 posts / 0 new
Last post
How can I use the international character sets(Korean)?

Thanks for your reply previous question.
I have resolved this issue through removing the particular lines.
and I also guess this issue due to the Unicode.
The language of my Window and Excel is Hangul - Korean language.
and the other ways, I have changed my the locale of window and then It was done well.
but I had another problem.
After I have changed the nation english name to Hangul,Korean language at the file - data_example_for_import_worldmap.xls
ex) chana -> 중국
I have imported this file and saved and played StatPlanet.exe file.
and when I pointed a mouse at the china location, it displayed strange character.
How can i resolve this issue??
Could you give me your a favor one more??
I should change the english nation name to Hangul-Korean nation name.
ok~ I expect your reply~ thanks
I have seen the FAQ.
To use them, please follow these steps:
1. Remove the files "data.csv" and "settings.csv" in the main directory and also in the directory 'web'.
2. In the StatPlanet Data Editor, go to the sheet "Settings". Under Startup options - Data format, select: TXT (tab-separated values). Then click on “Save settings”.
3. The international character sets can now be used in the desktop version of StatPlanet Plus. The web version does not include the international character set by default. This is only available in the purchased/licensed version on request.
The following character sets are available:

  • Armenian
  • Chinese (All character sets)
  • Cyrillic (for Russian, Serbo-Croatian and Tajik, amongst others)
  • Devanagari (for Hindi, Marathi and Nepali, amongst others)
  • Greek
  • Japanese (All character sets)
  • Korean (All character sets)
  • Latin I, Latin Extended A, Latin Extended B, Latin Extended Add'l
  • Thai

I have done like this.
But, also now I cannot see the Korean Character.
How can I do?? please??
I want to convert all of the english character to korean character in data.

StatSilk's picture

Currently only the 'shapefile map edition', desktop version (StatPlanet.exe) supports international fonts. For the other versions, a license needs to be purchased. Otherwise you will indeed see strange symbols.
To test if it is setup correctly, you could try opening the file 'data.txt' and you should see the correct characters there. Is that the case, and are you using the 'shapefile map' version? (Also the files 'settings.csv' and 'data.csv' should be removed.)