4 posts / 0 new
Last post
Fresh download of statplanet plus doesn't work

I just downloaded Statplanet Plus. There's four versions included. Two of them work, two of them don't. 
The "World Map" and the "Shapefile Map" open and just show "Statplanet" 
"Custom flash map" and "USA map" load just fine.
I didn't change anything, just unzipped a fresh download.
I'm running Falsh 10 on a Windows 8.1 Pro. I tried on a second laptop too, with the same result.
Did not find similar problems using Google, my apologies if my Google skills failed.
Edit: I have an older version of Statplanet Plus running too, that works just fine (editor version is 1.4)

StatSilk's picture


Sorry to hear about this problem. At this end, all four editions work when testing with a fresh download. Just to confirm, were you using the following download link? 


Would you be able to indicate if it is the desktop version (StatPlanet.exe) that is not working, or the web version (StatPlanet.html in the web folder), or both?

It may be that you need to upgrade Flash Player to 11 or higher if possible: http://www.adobe.com/go/getflash. The latest version of Flash is 17








Never knew trying to update Flash could make you feel like such an idiot. In Chrome I have a version 17, in Internet Explorer I have a version 11. Somehow, the "usa map" loads in a Flash 10 environment, the "world map" in version 11. I haven't been able to update the IE Flash version - this has to be done through Windows Update, apparently, and that thing is unaware of any updates at all.
The good news though: all the html versions work, and I found out that the exe's also work now, if I keep them on my local computer, as opposed to on the network drive we're supposed to use.

StatSilk's picture

Thank you for your update. The web version should only require Flash 9. I am not sure what could be causing the issue on the network drive, but glad to hear it works locally.