2 posts / 0 new
Last post
Dates stripped out on import

I am trying to import a straightforward Excel file that has 4 indicators, 4 dates, and several countries.  

When I import, no matter what dates I put in or what format the dates are in (number, text, date), the dates are all stripped and replaced with "2007" following the import.  My dates happen to be month specific.  I thought perhaps that was a problem so I experimented, replacing all dates with just years (fake, of course, which is undesireable).  Still, every year got stripped out and replaced with "2007" (which isn't in my data set).

I've also run tests where I structured my source data to look the way it's supposed to after the import (date on one row, one column, associated indicators for each year in next column over and one row below), but the dates are always stripped out and replaced with this mystery year "2007".  I even redownloaded the original file, StatPlanet_data_editor.xls, thinking the copy I had been working with may have gotten corrupted.  Same result.  I've tried also saving my source data as "xls" instead of "xlsx".

I'm running out of ideas of how to add/format dates and the source file differently.  Data gets correctly associated with countries and indicators in the import, but without something so basic as dates, it's a mess.

What could I possibly be doing wrong?

StatSilk's picture

That is mysterious, if you would be able to send the file you are using by sending a message via the contact form? http://www.statsilk.com/contact
The only thing I can think of is that there is the number 2007 in your data file, and the import macro thinks this is the year for the whole data set. But in any case I would like to see the data file if possible so the macro can be corrected.
On another note, importing of dates is currently under development (the macro currently only detects years) and this update should be released soon.