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1.  What is StatPlanet 

StatPlanet is a powerful interactive data visualization and mapping tool. It is used by international organizations 
such as UNESCO, SACMEQ and the Global Environmental Facility to communicate and more easily interpret 
data. One of the greatest strengths of StatPlanet is that it enables also non-technical users to explore statistics 
through its user-friendly interface. Moreover, the software automates the normally complex processes of 
converting raw data into interactive maps and visualizations. This enables even non-technical users to create 
interactive maps and visualizations with relative ease. The software can be downloaded and used free of charge. 

Three versions of StatPlanet are currently available: StatPlanet, StatPlanet Map Maker and StatPlanet Graph 
Maker. The original StatPlanet comes with data for over 250 indicators on world development, and for 210 
countries, in the following domains: demographic, education, environment, gender, health and socio-economic. 
The data comes from many different sources, such as UNESCO, SACMEQ and the World Health Organization. 
StatPlanet Map Maker and Graph Maker are downloadable versions of StatPlanet through which it is possible to 
add and visualize your own data, as well as import your own map boundaries. They are available both as a 
stand-alone application for offline use, and as a web-based application which can be published online.  

The aim of StatPlanet is to promote evidence-based decision making by improving and facilitating the 
communication and interpretation of information. StatPlanet does this by providing (i) attractive interactive 
visualizations which facilitate the interpretation of information, (ii) a user friendly interface that is accessible 
also to non-technical users, (iii) automated data visualization (including the processes of merging and 
synchronizing data from different sources), and (iv) an easy to disseminate software system which can enable 
anyone to explore and create data visualizations - regardless of technical skills, availability of Internet 
connectivity, and computer hardware or software. 

StatPlanet was conceptualized and is being developed by Frank van Cappelle since 2005. Since 2008, the 
development of a tailored version of StatPlanet is being undertaken as part of the SACMEQ research 
programme at the UNESCO International Institute for Educational Planning (IIEP). 

For more information: 

• SACMEQ website: http://www.sacmeq.org/statplanet 

• UNESCO website: http://www.iiep.unesco.org/?id=703& 
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2. StatPlanet system requirements 

StatPlanet was designed to be usable in as many places as possible. It can be used online as well as offline for 
those without an Internet connection. It is very small in size (less than 3 MB), which makes it easy to 
disseminate. For example, it can be distributed via USB flash drive (USB stick) and is small enough to send as 
an e-mail attachment. The software does not require installation. This is important for dissemination as many 
people do not have the necessary administrator rights on their workplace PC to install new software.  

StatPlanet runs in the Adobe Flash Player, which has the following minimum system requirements1. As can be 
seen in the table the system requirements are low, and any computer purchased within the past 7 years should be 
able to run StatPlanet. 

Windows® Macintosh Linux® 

Intel® Pentium® II 450MHz, AMD Athlon™ 
600MHz or faster processor (or equivalent) 

PowerPC® G3 500MHz or 
faster processor 
 
Intel Core™ Duo 1.33GHz or 
faster processor 

Modern processor (800MHz 
or faster) 

128MB of RAM 128MB of RAM 512MB of RAM, 128MB of 
graphics memory 

128MB of VRAM* 

*Recommended for GPU hardware acceleration–dependent features. Flash Player will use software mode for systems 

that do not meet the system requirements. 

 

 

 

 

                                                           
1
 http://www.adobe.com/products/flashplayer/systemreqs/ 
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3. StatPlanet features and user guide 

 

 

3.1 Thematic map 

 

Choropleth Map 
This is the main thematic map type in StatPlanet. The map legend shows which map colors are 
associated with each data range (for example, higher values may be shaded in increasingly 
darker colors). Both the map colors and the data range can be customized (see Map legend 
below). In version 2.1, the possibility of creating qualitative or descriptive maps was 
introduced. These types of maps convey non-numerical information, such as which languages 
are spoken in different regions. 

 

Proportional Symbol Map 
A proportional symbol map scales symbols (usually circles) according to the indicator being 
mapped. In Statplanet the symbol can represent either a country or a region within a country. To 
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create one, click the 'proportional symbol map' button in the bottom-left corner of the screen. 
The proportional symbol map is overlaid on top of the choropleth map. If you have bookmarked 
an indicator, the symbol map represents the data for the bookmarked indicator, whereas the 
choropleth map represents the data for the selected indicator. (If the bookmarked indicator is 
currently selected, both the symbol map and the choropleth map represent the bookmarked 
indicator).  

  

Select country on the world map 

• Mouse over country: Moving the mouse over a country on the world map brings up a 
popup containing information about that particular country for the selected indicator (as 
well as the bookmarked indicator, if there is one). In addition, the country data for all 
indicators in the current category is shown in the indicators window. 

• Click on country: You can select a country by clicking on it in the map. This will 
highlight the country in the graph, and can also be used to define a custom region. See 
also the country selection window. 

  

Map legend 

Map colors: Clicking on any of the colors in the legend will bring up a color selection window. 
In this window you can change both the colors (either Sequential or Diverging color schemes), 
as well as the number of color classes (between 3 and 9). The color schemes are from the Color 
Brewer website (http://colorbrewer2.org/), which is an excellent resource for more information 
on selecting map colors. 

Data range: To adjust the data range of the map legend, click on the top or bottom value. Use 
the popup to increment or decrement the value, or enter a whole new value. The intermediate 
values will be adjusted automatically. 

Custom maps (national / regional / state maps etc.) 

You can use StatPlanet Map Maker to insert your own maps, using the included map template 
(map.fla). This requires the Adobe Flash software. (See: 5. Importing a map into StatPlanet) 

 

Save map 
Tou can find the save map button in the bottom-left corner of the screen. To change the image 
type, size or quality, use the options window. This feature is only available in the online version 
on the StatPlanet website. However, it is possible to save an image of a map produced with your 
own data if you download StatPlanet Map Maker. You need to open StatPlanet in the directory 
'Offline', click the icon shown on the left, and then follow the on-screen instructions. Please 
include a reference to StatPlanet if you are publishing the image. 

 

Map navigation controls:  

The map zoom controls are normally hidden from view. Move the mouse towards the bottom-
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right of the screen to make them appear. 

• Zoom: You can zoom in and out of the map using the 'zoom in' and 'zoom out' buttons, 
or by dragging the zoom slider up or down. If your mouse has a scroll wheel, you can 
also use this to zoom in and out.  

• Moving the map: click and drag the map with the mouse to move it to a new position. 
• Restore map position: the button shown on the left restores the map to the original 

coordinates for the selected region.  

3.2 Indicators window 

 

Select category 
Use the drop-down menu in the top of the indicators window to select a new category (online 
version only). 

 

Select regions  
Use the drop-down menu in the top of the indicators window to select and zoom into a 
different region, such as 'Africa' or 'Europe'. It is also possible to select countries to define a 
custom region (see Country selection window). 
 

 
 

  

Indicator bars 
The bars are scaled in proportion to the maximum value of that particular indicator for all 
countries in the selected region. For example, if the value for country X is 20 and the 
maximum value for all countries is 100, the bar will be scaled at 20%. You can also scale the 
bars as a percentile by selecting 'Percentile' as the Visualization type in the options window. 
 

 

Bookmark indicator  
Click the 'star' button in the indicators window to bookmark the selected indicator. The 
bookmarked indicator will stay even when you switch to another category. This allows you 
to (i) create scatter plot graphs, (ii) compare the bookmarked indicator with indicators from 
other categories, and (iii) compare two indicators through the choropleth map (representing 
the selected indicator) and the proportional symbol map (representing the bookmarked 
indicator). 

  

Indicator definitions  
If a definition exists for an indicator, the definition will appear in a popup when moving the 
mouse over the indicator. The definition only shows for the indicator which is selected or 
bookmarked. 

3.3 Graph window 

 
Bar chart  
Click the 'graph' button in the bottom-left corner of the screen to open or close the Graph 
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window. You will find the same graph button in the graph window. Use this button to switch 
between horizontal and vertical bar charts. 
 
Use the "sort" button to sort the graph from lowest to highest, highest to lowest, highest to 
lowest starting in the middle, or alphabetically. 

 

Time series 
In the top left of the Graph window (see "Bar chart" above) you will find the time series button. 
When you click on this button, a list of countries appears which you can add to the time series 
graph. Click on a country to add it to the graph, and click on it again if you wish to to remove it. 
(See also Country selection window below). 

Use the "sort" button to sort the time series labels. 

 

Scatter Plot 
In the top left of the Graph window (see "Bar chart" above) you will find the scatter plot button. 
Clicking on the button will automatically use the selected indicator as the x-axis variable. You 
need to select a second indicator as the y-axis variable. 

The x-axis and y-axis variables can be selected in the Graph window (see below), or in the 
Indicators window (see Bookmark indicator  above). 

Press the ‘play’ button to see an animation of changes over time, with each bubble moving to 
the corresponding x and y positions (depending on whether data is available for each time 
interval). If ‘Show trails’ is selected (next to the play button), each bubble will leave a trail to 
mark previous positions over time. 

 

Select x-axis / y-axis indicator 
Click on the x-axis or y-axis label, then select an indicator from the drop-down menu. 

Use the drop-down menu in the top of the graph window to change the scale of the 'bubbles' 
according to a selected indicator. 

 

Use the 'options' icon in the graph window to show or hide the trendline. Move the mouse over 
the trendline to see the slope and trendline equation. 

  

Adjust graph size 
To change the graph size, move the mouse to the sides or corners of the graph window until you 
see the cursor change to look like the one shown on the left. Click and hold down the left mouse 
button, then drag the window to the size you want . Release the mouse button once you have the 
right size. 

 

Adjust graph scale 
The graph scale can be adjusted by clicking on the top or bottom graph values. The value can 
then be edited in the popup window. 
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3.4 Options window 

 
Click the 'options' button in the bottom-left corner of the screen to open the options window. 

  

Map:   

• Map colors: map background, map borders, map text color, map text outline color, etc.); 

• Map text size; 

• Map symbol size (proportional symbol map symbols); 

• Map legend - estimate best value distribution: adjust the values so that there is a more 
equal distribution of countries for each color class. This will usually result in a map with 
a better distribution of colors. If this is switched off, the value range for each color class 
will be set at equal intervals based on the highest and lowest value in the data range. 

• Map legend - show maximum & minimum values 

• Map legend colors. 

Graph/Chart:   

• Graph colors: background, bar & scatter points, scatter point borders; 

• Graph text size; 

• Transparency level of graph area (bars / bubbles); 

• Size of bubbles (scatter plot graph); 

• Bullet graph. 

General options:  

• Animation duration; 
• Decimal places shown; 
• Adjust the map/graph scale: StatPlanet automatically adjusts the map and graph scale 

to suit the data set. However, in some cases you may wish to keep it fixed, for example if 
you made some changes to it yourself. You can set (or prevent) the automatic updating of 
the map/graph scale on (i) changing indicator, (ii) changing region, (iii) changing year. 
The default setting is for StatPlanet to adjust the scale when changing indicator or region, 
but not year.  
If you have chosen to not have the map scale updated, the map legend has a shortcut 
which you can use to 'refresh' the map legend at at any time for the current indicator, 
year and region:   
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• Choose to view statistics as percentiles. 

Save/export map: (online version only) 

• Set the image type: PNG or JPEG 
• Change the image size as % of original 
• Change the image quality (for JPEG images only) 

3.5 Data table window 

 

Click the 'table' button in the bottom-left corner of the screen to get a data table of the selected 
indicator. If an indicator has been bookmarked, the data for both the bookmarked and selected 
indicator will be displayed. The table also shows the mean, standard deviation and range. 

 

Online version (StatPlanet website): Save / Export table 
You can save the table as a .CSV file which can be opened by most spreadsheets (such as 
Excel). You can find the save table button in the top-right corner of the table window. 
 

 

Offline version: Copy table 
The offline version of StatPlanet does not allow you to save the data as a file. Instead, you can 
copy the entire table into Excel using the 'copy' button, and then 'paste' it in Excel. If you do not 
have Excel, you can also do the following: (i) paste the data into a basic text editor such as 
Notepad, (ii) save the document as 'data.html', (iii) open the file using your Web Browser. 

3.6 Selecting countries 

Countries can selected in various ways. An efficient way of finding and selecting a country is through the 
country selection window, as explained below. However, a country can also be selected by clicking on it in the 
world map, in the data table window, or in the bar chart or scatter plot graph. In each case the country will be 
highlighted in all of these StatPlanet components. 

 

Click the 'select' button in the bottom-left corner of the screen to get a list of countries. Then 
click to select the countries you wish to show on the map or in the graph window. To narrow 
down the list of countries, select a region from the drop-down menu in the top-right corner of 
the screen. You can also press the first letter of a country name to quickly jump to a country in 
the list. 

 

Select button 
Press the Select button to confirm your selection. Any variables which are not selected will be 
removed from view.  
Note: for the time series graph, there is no need to press this button as the countries will appear 
in the graph window as soon as you click on them. 
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Deselect All button 
Press the Deselect All button to clear your selection. 
 

 

Refresh button 
The Refresh button . It only appears after you have clicked the Select button. 

  

 
Remove countries 
To remove countries, select the countries you wish to remove and press this button.  

 

3.7 Time slider 

 

Use the slider or click on the arrow buttons to change the year. Click on the play button to show changes over 
time as an animation, starting from the beginning. The animation speed can be set in the Options window. 

3.8 View menu (show/hide items) 

 

Move the mouse over the 'View' button in the bottom-left of the screen to see various options 
for showing or hiding map & graph elements, and other StatPlanet components. 

• Show or hide country/region names on the map or graph (country names can be 
shown in full, in abbreviated form or as ISO3 codes); 

• Show or hide country statistics on the map or graph (country statistics can only be 
shown on the horizontal bar chart); 

• Show or hide the map popup and its components - bar chart, indicator and statistic; 
• Show or hide various windows. 

3.9 Window options (resizing/scaling) 

  

Shrink / enlarge windows: Use the buttons shown on the left to shrink or enlarge the 
StatPlanet windows. This may be useful for space management when you have several 
windows open at the same time, or to focus in on certain areas. 

  

Minimize / maximize windows: Use these buttons to minimize or maximize the 
windows. The indicators window has a special minimized state in which indicators 
can still be selected. 
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Adjust graph window size 
Drag and drop the graph window borders to adjust the size. 

  

Fullscreen: Click on this button in the bottom-left of the screen to either switch to 
fullscreen mode, or go back to normal window mode. 

 

Additional notes:  

• When switching categories, StatPlanet will remember which year was selected and check if data exists 
for this year in the new category. If there is no data for this year, it will select the year closest to the 
previously selected year for which data is available in the new category. 

• When switching maps (e.g. world map to country map, or from regional map to district map), StatPlanet 
will check if the same category and indicator exist in the new map. If it cannot be found, the first 
category/indicator in the data set will be selected. 
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4. Add or Import Data using StatPlanet Map Maker 

4.1 Basic steps for adding data 

Note: to add your own data you need to download StatPlanet Map Maker: http://www.sacmeq.org/statplanet 

Once you have downloaded the ZIP file and extract the files to a location of your choice, you can get started with the 

steps below. 

 

STEPS: 

1. OPEN 
data editor 
 

Open the file StatPlanet_data_editor.xls – make sure that Macros are enabled. 
To remove the example data, click on the button Clear data.  

2. IMPORT 
data 
 
 

Click on the Import data button and select the file2 containing the data you wish 
to import. See also: 
- 4.2: Importing data  
- 4.7: Adding data manually (does not require Excel).  

3. SAVE 
data 

Click on the Save data button, saving the data as data.csv  
(a comma delimited text file).  

A copy of the file is also saved in the directory ‘web’ for publishing online, and 
one in the directory ‘offline’ for viewing in a stand-alone desktop application. 

 

 
AFTER STEP 3, RUN STATPLANET:   

• Click on StatPlanet.exe  
• Browser: In the directory ‘Web’ click on StatPlanet.html to run StatPlanet in your web-browser. 

To publish StatPlanet containing your data online, all you need to do is to upload the contents of the folder Web to a web-
server. This folder contains the following files: 

• StatPlanet.html   (the webpage which displays your interactive map) 
• StatPlanet_small.html (alternative with smaller map embedded inside a webpage) 
• StatPlanet.swf   (file which shows loading progress) 
• content.swf   (the actual software) 
• data.csv    (the data) 
• AC_RunActiveContent.js  (required to run ‘Flash’ content) 

 
 

 

                                                           
2
 A number of sources of publicly available data sets are linked from the StatPlanet website: 

http://www.sacmeq.org/statplanet/data.html 
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Contents of StatPlanet_Map_Maker.zip 

• Docs: 
- User Manual (User_Manual_StatPlanet.pdf) 
- StatPlanet Software License (License_Terms.pdf) 

• World_Map 
- Create interactive maps using your own data, with the included World Map 
- It is possible to focus the map on a particular region on loading StatPlanet 
(e.g. Africa, Asia, Europe, etc. or a custom defined region) 
- Click on StatPlanet.exe to launch, or StatPlanet_data_editor.xls to edit 

• Custom_Map 
- Import your own map into StatPlanet 
- map.fla = the map template to import your map  
(requires Adobe Flash CS3 or higher) 
- map_example.fla = an example map using the province map of Kenya 

 

4.2 Importing data 

The Data Editor enables the automatic importing of data. You can import any file which can be read by Excel (e.g. CSV, 
TXT, XLS, XLSX). The Data Editor automatically recognizes the structure of your data, and can also recognize almost all 
the different spellings of country names. Therefore, unless there are spelling mistakes in the country names, in most 
cases the import should go smoothly. 

The Data Editor will look for country names and associated statistics in your file wherever they are located, and will 
automatically restructure the data in the format that is accepted by StatPlanet. 

Note that for the import to be successful, country names should not appear more than once in the data file. Also note that 
StatPlanet sees a "dot" as the decimal separator. In case of problems, please see Troubleshooting below. 

Headers not recognized 

Headers (or variables) in the data file which are not recognized are displayed once the import is complete. For example, if 
in your data file the country ‘Afghanistan’ is indicated with the abbreviation ‘Afg', this abbreviation will not be recognized by 
the data editor. To fix the problem, go to the Excel sheet 'Country names' and add ‘Afg’ in an empty cell below the 
corresponding country - ‘Afghanistan'. You can use the same approach for other headers in your data set so that the 
import macro can correctly identify them. Then, run the import macro again to import the data correctly. 

Note that the import macro removes spaces in country names and converts special characters (e.g. "é") into regular 
characters (e.g. "e") during the import. This allows for a wider range of country name spellings to be detected. Whether 
country names use upper or lowercase does not matter. The data import macro recognizes English and French country 
name spellings and a number of variations of these spellings. Data importing has been successfully tested with many 
different sources - each of which have different data structures and country name spellings (including data from IMF, 
PISA, SACMEQ, UIS, UNAIDS, UNDP, UNESCO, UNICEF, UNSTATS and WHO). 
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4.3 Troubleshooting 

If you have saved your data but it cannot be read by StatPlanet, most likely there is a problem with the data structure. 
Please see point 4 below to see how to structure data by year (or other time point). Data should start with the more recent 
time point. Also make sure that the indicators listed for each year are exactly the same, and are listed in the same order. 

If the import fails, check your data file for the following issues: 

1. Spelling of country names: If the spelling of any of the country names cannot be identified, the data for these 
countries will not be imported. 4.3 Importing data above explains how to solve this problem. 

2. Merged cells: Most commonly the merged cells are 'headers' For example, two columns or rows of data may 
have the same header (e.g. "Life Expectancy"). To fix this problem, split the merged cells (Right click -> Format 
Cells -> uncheck the box 'Merge cells'). One of the two cells will now be empty, leaving one of the columns (or 
rows) without a header. To fix this, copy and paste the header into the empty cell as shown below.  
 

Life Expectancy 

 

Life Expectancy Life Expectancy 

2000 2005 2000 2005 

76 76 76 76 

59 62 59 62 

 
3. Country names appear more than once: If the same country name appears more than once in your data file, 

the import macro will only import the data associated with the first one. The easiest way to fix this problem is to 
create separate files for each list of country names, and import them one by one. 

4. No year indicated in the data file, or cannot be detected: 
All indicators are arranged according to year. You need to add the year to your data set as the header of a row or 
column (depending on how your data is structured). Alternatively, you can import the data and add the year 
afterwards. The data needs to be structured as follows (see for example the structure of the sample data in 
StatPlanet_data_editor.xls): 
 

• Group (sort) your indicators according to year. Insert a new row above each group of indicators. In this 
new row add the year in the YEAR column. Leave the neighbouring cell in the INDICATOR column blank; 

• Note that the YEAR column should be blank in the cells next to the indicators: 
 

YEAR INDICATOR 

2001  

 indicator1 

 indicator2 

2000  

 indicator1 

 indicator2 

 

5. Decimal point: StatPlanet reads a "dot" as decimal separator (for example 0.75), and a "comma" as a thousands 
separator (for example 1,000). 
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4.4 Optional parameters 

In StatPlanet_Data_Editor.xls, there are several columns which can be used to define optional parameters. The 

different columns and their usage is explained below. 

1. SOURCE: The source of your data can be added in the same row as the year, and can optionally be specified for 
each year in the dataset (otherwise it is assumed that the source specified for the first year in the series is the 
same source as for the other years). You can choose to use HTML code if you want to add a link to the source 
website, for example: <a href=’http://www.mysource.com’>My Source</a> 
 

2. DESCRIPTION: Add a description for each indicator in this column, which will appear as a popup in StatPlanet 
when moving the mouse over the indicator.  
 
To reduce file size, you never have to repeat a description more than once: 
 

(i) If you have data for several years, you only need to add a description for the list of indicators below the 
first year in the series. When a different year is selected, StatPlanet will automatically grab the description 
from the first year. (Note that for each year you need to have the same list of indicators, in the same 
order). 

(ii) If you have two or more indicators with the same description, you only need to enter the description once. 
For the other indicators, instead of a description enter the Excel row number where the description you 
want to re-use is located. 
 

3. UNIT: The unit only needs to be specified for the list of indicators below the first year in the series. 
 

4. MAP: In this column you can customize the map legend for each indicator as follows: 
 

(i)  Map legend with custom values 
(ii)  Map legend with custom colors 
(iii)  Map legend with custom colors & values 
(iv)  Qualitative map legend: custom colors and labels 

 
These examples are included in StatPlanet Data Editor, using the ‘Life Expectancy’ data from WHO to 
illustrate the first three types of map legend. The Qualitative map legend uses fictional data. Additional 
customizations can also be specified in the sheet ‘Settings’  
(See also: 4.8 Changing settings and appearance). 
 

(i) Map legend with custom values  
 
Use the following format to specify the values for the map legend, as well as the number of color 
classes: 
0=[value0] 1=[value1] 2=[value2] 3=[value3] 4=[value4]  
etc. 
 

• Example 1a: A legend with 4 color classes: 
0=[55] 1=[40] 2=[20]  
 

• Example 1b: A legend with 5 color classes: 
0=[70] 1=[65] 2=[60] 3=[55] 
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                                                                            Map legend for Example 1b: 

With max / min values 
hidden 

With max / min values 
shown 

> 70 70 - max value 

65-70 65-70 

60-65 60-65 

55-60 55-60 

< 55 min value – 55 

 
 

(ii) Map legend with custom colors 
Use the following format to specify the colors for the map legend, as well as the number of color 
classes: 
0=[color0] 1=[color1] 2=[color2] 3=[color3] 4=[color4]  
etc. 
 

• Example 2: A legend with 4 color classes: 
0=[0x238B45] 1=[0x66C2A4] 2=[0xB2E2E2] 3=[0xEDF8FB] 

 
(iii) Map legend with custom colors and values 

Use the following format to specify the colors for the map legend, as well as the number of color 
classes: 
0=[color0][value0] 1=[color1][value1] 2=[color2][value2] 3=[color3][value3] 4=[color4] 
 
Note that this format is slightly different from the previous ones, because 5 colors are specified 
(colors 0 to 4) but only 4 values (values 0 to 3). As illustrated in example 1b above, a legend with 5 
color classes requires only 4 values to be specified (a legend with 4 color class requires only 3 
values, and so on). 
 

• Example 3: A legend with 4 color classes and custom values: 
0=[0x2171B5][3] 1=[0x6BAED6][2] 2=[0xBDD7E7][1] 3=[0xEFF3FF] 
 

(iv) Qualitative (descriptive) map legend 
Use the following format to specify the map legend colors, the corresponding labels, as well as the 
number of color classes. Countries are assigned a value which corresponds to one of the numbers 
below. For example, if the country ‘Afghanistan’ is given a value of ‘0’, it will be associated with 
‘color0’ and ‘label0’. 
 
0=[color0][label0] 1=[color1][label1] 2=[color2][label2] 3=[color3][label3] 4=[color4][label4] 
etc. 
 

• Example 4: A legend with 5 color classes: 
0=[0xE41A1C][Category 1] 1=[0x377EB8][Category 2] 2=[0x4DAF4A][Category 3] 
3=[0x984EA3][Category 4] 4=[0xFF7F00][Category 5] 

 
 



18 

 
 

          Map legend for Example 4: 

Color Label 

0xE41A1C Category 1 

0x377EB8 Category 2 

0x4DAF4A Category 3 

0x984EA3 Category 4 

0xFF7F00 Category 5 

 
 
 

5. GRAPH: If you wish to use your own maximum and minimum values for the graph, you can set them here.  
Specify the minimum and maximum values in parentheses in the following format: 
 
[min value][max value] 
 
For example, for a minimum value of 0 and a maximum value of 80, enter the following: 
 
[0][80] 
 

6. SYMBOL: Deprecated in StatPlanet v2.2 to reduce the file size. You can specify the symbol you wish to use for 
the proportional symbol map. If none are specified, StatPlanet will use the circle symbol. To indicate that you want 
to use a different symbol for a particular indicator, enter one of the following in the corresponding row in the 
SYMBOL column:  

(i)  book 
(ii)  electricity 
(iii)  pc 
(iv)  phone 
(v)  stickfigure 
(vi)  typewriter 
(vii)  water 

 
7. OPTIONS / TYPE: A number of new options are currently being implemented to enable greater control over the 

visualizations in StatPlanet. In future versions the two columns OPTIONS and TYPE will be used to specify these 
options. 
 

8. Country information on mouse over country 
Country-specific information can be shown in a popup when the mouse moves over the country on the world map 
or in the graph window. This information needs to be added in the very first row in the empty cell below the 
corresponding country name. (These cells are empty, because country data starts in the next row).  
 
You can insert plain text, for example:  
 

My text 
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Or you can insert text as HTML with formatting, for example:  
 

<font size="15" color="#347C17">My text</font> 
 

9. Link to to web-page or document when clicking on a country: 
Links to documents or web-pages can also be specified in the row below the corresponding country name. The 
document or web-page will open when the user clicks on a country for which a link has been specified. An 
example of a link would be: 
                                                http://www.mywebsite.com/document.pdf 
 
It is also possible to have both text and a download link, by inserting the link as HTML code. For example: 
 
         <a href=http://www.mywebsite.com/document.pdf'>Insert additional information here</a> 

4.5 Adding other types of data (provinces/continents/etc.) 

StatPlanet Map Maker can be used to graph any kind of data - not just country data. You can add your own types of data 
as follows: 

1. Open StatPlanet_data_editor.xls and in the worksheet "Import" go all the way to the last country at the end of row 
2. 

2. In the empty cells in row 2, add the names of your new data types (for example “Sub-Saharan Africa”). 

3. Press the button Save data. The names of your new data types have now been added.  

Note: It is possible for the ‘Import’ function to recognize the types of data you just added. Simply add them in the sheet 
'Country names', but make sure you add them in the correct columns (i.e. the same columns to which you added them in 
the sheet ‘Import’). 

4.6 Custom regions 

You can add, remove or change the region names in the worksheet ‘Data’. To define which countries are in your custom 
region, add the ISO3 codes for those countries in the same row as your region. You can also define the region 
coordinates and zoom level so that the map will zoom into the region you have defined. In StatPlanet you can get the map 
coordinates and zoom level by moving the mouse to the bottom-right corner of the screen (so the zoom controls appear). 
The map coordinates and zoom level will be shown in the bottom of the screen. 

4.7 Adding data manually / without macros 

You can also edit the data file directly (for example, if you are using software other than Excel). Open the file data.csv 
and add or copy your data below the header “GLOBAL” i.e. from row 16 onwards.  

If the software you are using can open Excel files, you can also edit the data in the file StatPlanet_data_editor.xls, inside 
the worksheet ‘Data’. This worksheet has been formatted for easy editing.  

When you are done, save the data as a 'comma seperated' csv file and replace the file data.csv. 
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4.8 Changing settings and appearance 

Go to the worksheet ‘Settings’ to customize StatPlanet, such as the appearance of the map. After making any changes to 
the settings, press the button Save Settings. You can try out all the different options ‘live’ in StatPlanet (see for example 
the ‘Appearance’ tab in the Options window).  

4.9 Changing language and translation 

StatPlanet has been translated in French, Spanish, Bahasa Indonesia (courtesy of the Government of Indonesia) and 
Dutch. You can use any of these translations or create your own translation in the worksheet ‘Text-Translations’. Click the 
corresponding save button to save the translation you wish to use. 
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5. Importing a map into StatPlanet Map Maker 

To create custom interactive maps using StatPlanet, you need the following: 

• StatPlanet Map Maker 

• Adobe Flash CS3 or higher 

• A map file in vector format, either Adobe Illustrator (.ai), FreeHand (.fh*, .ft*), or Adobe Flash (.swf). 

For an example of what the final result could look like, see the file 'map_example.fla' (shown below). 

� See also: 5.2 Converting images into a suitable vector format. 

 

StatPlanet Example Map (map_example.fla) 
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5.1 Using the map template 

To prepare the map so it can be loaded into StatPlanet, you need to open the map template - 'map.fla' - which is in the 
'StatPlanet_Custom_Map' folder. This file contains the following four layers: 

• Map layer: This layer will contain the map shapes (e.g. regions or provinces). 

• Borders layer: This layer will contain the map borders. 

• Txt layer: This layer will contain the text labels for your map. 

• Txt lines layer: You do not need to make any changes to this layer. (It is in this layer that lines will be drawn when 
StatPlanet is opened, linking the text labels with the corresponding map region). 

Step 1. Map layer 

Before inserting your map into the map template (map.fla), it may be easiest to edit it first in a new document. 

• Open a new document (File -> New).  

• Import your map. Go to File -> Import to Stage, and select your map file. 

• Once the map is imported, select and remove the details you do not need such as text labels, roads, etc. (Click 
outside the selected area to deselect it, then click on any of the details you wish to remove and press delete). 

• Select all (Edit -> Select all).  

• Break apart the shapes of your map by pressing CTRL+B (or using the menu: Modify -> Break Apart). You may 
need to repeat this several times until the shapes cannot be broken apart any further.  

o What to do if a rectangle appears which covers your map: 
In some cases a rectangle may suddenly appear which was previously hidden from view. If this is the 
case, click anywhere outside the selection area to deselect it. Then click on the rectangle and press 
'delete'. You should now see the map again. (Note: if you did 'Break Apart' one too many times, the 
rectangle and your map merge, and the map disappears. You will need to go back and redo this, and 
remove the rectangle while it is still a seperate shape). 

• Select all (Edit -> Select all).  

• Copy the map (Edit -> Copy). 

• Open the map template (map.fla). 

• Select the first frame in the timeline in the layer 'map' (normally in the top of the screen, see also the example 
screenshot above - the first frame looks like a white rectangle with a circle in it). 

• Paste your map (Edit -> Paste in Place). 

• Double-click on the map borders. This should normally select all the borders in one go. Otherwise, hold down the 
Shift key and double click on the remaining borders. Once you have all your borders selected, change the border 
thickness in the Properties Panel below. Click on the drop-down which currently has 'Solid -----------' selected, and 
change this to 'hairline'. If the borders are different colors, make them one color by clicking in the color selection 
box to the left of the border thickness selection. Select any color (for example black). 

• Now select the different shapes of your map one by one and convert each of them into a Movie Clip. To convert 
them into a Movie Clip, press F8 (or use the menu: Modfiy -> Convert to Symbol).  
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o What to do if shapes do not seperate properly: 
In some cases the shapes of your map may not have seperated properly, because the borders are not 
properly joined up. You can either draw existing borders to make them join up, or draw them in using the 
pencil tool. To join them up, you can click on the edge of one of the lines just at the point where it does 
not join up, and drag the line to where it should join. Alternatively, click on the Pencil Tool in the Drawing 
Toolbar (normally on the left). Then draw in the lines where the gap exists. If this is done correctly, the 
shapes should now be seperated. 

o What to do if your map consists only of map boundaries, not shapes: 
If your map consists only of map boundaries or borders, you can fill the boundaries with the 'Paint Bucket 
Tool'. Select the 'Paint Bucket Tool' in the Drawing Toolbar (normally on the left) and click within the map 
boundaries you wish to fill. It can be filled using any color. 

• Assign an instance name to each of the movie clips. The instance name can be entered in the properties panel 
which is normally below the stage (see also the example screenshot above). 

• The instance name cannot contain spaces. Therefore, you may wish to assign a 'code' rather than the actual 
name. The actual name can be defined later in the StatPlanet Data Editor, where it can include spaces. 

• The size / position of the map can be adjusted at a later stage in the Data Editor (in the Excel sheet 'Settings'). 

Step 2. Borders layer 

• Once you have created the map Movie Clips, your borders may have become hidden from view. To make them 
appear again, you need to select all the map Movie Clips you just created one by one, while holding the SHIFT 
key. Once you have selected all of them, select Edit -> Cut. You should see the map boundaries reappear.  

• Now select the map borders by double-clicking on any part of them. This should normally select all the borders in 
one go. Otherwise, hold down the SHIFT key and double click on any of the borders which are not yet selected. 
Once you have selected all the borders, press CTRL + G (or use the menu: Modify -> Group). 

• Once you have grouped all the map borders, you can place all the Movie Clips back again. Select Edit -> Paste in 
Place. While the Movie Clips are still selected, right-click on any of them, and from the popup menu select 
Arrange -> Send to Back. Now your map borders should appear on top of the map. 

• Click anywhere outside the selection area to deselect it. Then click somewhere on the map borders. This requires 
some precision so that you do not accidentally click on one of the map Movie Clips instead. Once you have 
selected the borders, go to Edit -> Cut. Then select the first frame in the 'borders' layer in the timeline panel, and 
go to Edit -> Paste in Place. 

• While the borders are still selected, turn them into a Movie Clip by pressing F8 (or using the menu: Modfiy -> 
Convert to Symbol). 

• In the Movie Clip properties panel below the stage, give the Borders Movie Clip the instance name: borders. 

Step 3. Txt layer 

• All the text label movieclips should be inside a 'container' movieclip called ‘txt container’. This is already included 
in map.fla. If you double-click on any of the text labels, you will go inside the 'txt container' movieclip. Now you 
can click on and move around the three labels which are included in map.fla. 

• To create more text labels for your map, click on any of the text labels, copy them (Edit -> Copy) and then paste 
(Edit -> Paste). Drag each of the text labels to their corresponding map region. 
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• You do not need to edit these text labels. All you need to do is give each of them an instance name corresponding 
to the ones you have assigned for the map regions. In StatPlanet, the text labels will automatically display a name 
and value according to its instance name. 

• Note: Do not change the size of the text labels (or its container movieclip). Instead, define the size of the map text 
in StatPlanet_data_editor.xls, under Settings (Map text size). 

Step 4. Publish your map file 

• Once your map is ready, publish the file (File -> Publish). 

• Go to the directory containing map.fla. You should see a new file, 'map.swf'. Copy and paste this file into the 
directory Offline (for the offline version of StatPlanet) and Web (for the online version of StatPlanet), replacing the 
existing 'map.swf'. 

Step 5. Linking the map in StatPlanet Data Editor 

• In StatPlanet_data_editor.xls, first insert the 'real names' of your map regions, and then the 'instance names' or 
codes which you used in the map file (map.fla). 

• In the sheet 'Import', replace the example names (which are Kenya province names) with your own names, in the 
order that you wish. Then press the button 'Save data'. 

• Go to the sheet 'data' (see the sheet names in the bottom left). The names you have entered should appear in the 
first row. A few rows lower you should see a list of example codes (CEN, COA, EAS, etc.). Replace these codes 
with the codes (instance names) you have used in the map file. The code in each column should correspond to 
the name given in the first row of the same column. 

• Go back to the sheet 'Import' and enter your data. You can also use the 'Import data' button to import your data 
from a file automatically. If the import fails, it is most likely because the names or headers in the file you are 
importing could not be recognized. In that case, you need to add them in the sheet 'Country names'. See also 
Importing data. 

• Once the data has been added, press the button 'Save data'. 

• Go back to the directory Offline and open StatPlanet.exe to see your map in action. Or go to the directory Web 
and open the file StatPlanet.html to open it in a web-browser. If you wish to publish your interactive map on a 
website, copy and paste the contents of the folder 'Web' to the web-server. See also the file 
'StatPlanet_small.html' for an example of how the map can be integrated into an existing web-page.  
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5.2 Converting images into a suitable vector format 

Converting a GIS shape file (.SHP) into a vector format recognized by Adobe Flash 

Maps for GIS (Geographic Information Systems) are commonly exchanged as ESRI Shapefiles. Such files can be 
converted into Adobe Illustrator vector files using software such as ArcGIS or MAPublisher. Converting the file in ArcGIS 
can be done as follows: select 'File -> Export Map'. In the 'Save as' drop-down select 'AI' as the file format. Then click on 
'Save'. Adobe Illustrator (AI) files can be imported directly into Flash.  

You may also wish to open the image first in Adobe Illustrator, export the image as a Flash SWF file, and import the SWF 
into Flash. Importing an SWF file sometimes leads to better results than importing an AI file. 

If you do not have access to such software, you could try a free Shapefile to SVG converter called shp2svg. See below for 
converting an SVG image into a format recognized by Flash. 

Converting a vector image (such as SVG) into a vector format recognized by Adobe Flash 

Use Adobe Illustrator to open the file, and then export the file into the right format. It seems that the best results are 
achieved when using Adobe Illustrator to export the image as an Adobe Flash SWF, then importing the SWF into Flash. 

If you do not have Adobe Illustrator, you could try converting the file using the free vector graphics editor Inkscape. You 
may also wish to try this free SVG2SWF conversion tool. 

Converting a Bitmap image into a vector format (e.g. GIF, JPG, PNG, BMP) 

It is impossible to perfectly convert a Bitmap image into a vector one, but with some experimentation it is possible to 
achieve good results. To convert a Bitmap image, first import it into Flash (File -> Import to Stage). Then select the image, 
and select Modify -> Bitmap -> Trace Bitmap. 

You will need to experiment with the following trace settings to get optimal results: 

• Color threshold: Increase this value to decrease the number of colors in the resulting vector image. (When 
comparing two pixels, if the difference in the RGB color values is less than the color threshold specified here, they 
are considered to be the same color). 

• Minimum area: Increase this value to decrease the number of shapes in the resulting vector image. This is the 
number of surrounding pixels considered when assigning a color to a pixel. 

• Curve fit: How smoothly the outlines will be drawn. 

• Corner threshold: Select how many corners you wish to keep. 

The following values illustrate what settings to use if you wish to create a vector that most closely resembles the original 
bitmap. However, the settings below are not recommended due to the large number of shapes created. These settings 
may also cause the Flash software to crash. 

• Color Threshold: 10  

• Minimum Area: 1 pixel  

• Curve Fit: Pixels  

• Corner Threshold: Many Corners 
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Manually tracing the outlines 

If automatically tracing the image does not lead to the desired results, you can draw the outlines by hand. Unless your 
map if quite large or complex, this is not necessarily a very long process. It can be done as follows: 

1. Convert the map into a Movie Clip (Modify -> Convert to Symbol). 

2. In the properties panel below, click on the 'Color' drop-down and select 'Alpha'. Change the value to around '30%' 
(so you can still see the outlines of the map clearly). 

3. Insert a new layer (Insert -> Timeline -> Layer). 

4. Select the Line tool for the Drawing Toolbar, and draw the outlines in this new layer following the outlines of the 
map in the layer below. Make sure that all the lines are touching. To draw a curve, first draw a straight line. Then, 
click somewhere in the middle of the line, and drag it one way or another. 

5. Select the Paint Bucket tool and click inside the borders to create your map regions. If it does not work, the 
borders you have drawn are probably not touching. Zoom in to see if you can detect the breach. 

6. Remove the bottom layer containing your bitmap image. 

7. Follow the steps in 5.1 to convert your map for use in StatPlanet. 
 

5.3 Importing GIS / Shapefiles. 

This requires StatPlanet Lite (see http://www.sacmeq.org/statplanet/StatPlanet-lite.html) 

Instructions for loading your own GIS shapefiles into StatPlanet: 

1. Go to the folder 'GIS_Shapefile_Map', and then the sub-folder 'map'. 

2. Remove the included map shapefiles (a USA map), and copy your own shapefiles here. 

3. Rename your files (e.g. xxx.shp and xxx.dbf) to map.shp and map.dbf 

4. Open the StatPlanet_data_editor.xls file. Click on the button 'Setup shapefile' (in the top-left). 

5. Select the map.dbf file in the 'map' sub-folder, and follow the instructions. 

6. Run StatPlanet.html to see the results with the included sample data. 

You can now start importing your own data for the map. 
Edit the StatPlanet.html to change the dimensions of the map. 
The font and interface components can be enlarged through the Excel sheet 'Settings'. 

You can find free shapefiles (regional / administrative boundaries maps) for most countries here: 

- Map Library - http://www.maplibrary.org/  - Public domain maps for most countries in the world. 
- UN SALB - http://www.unsalb.org/ - Second Administrative Level Boundaries data set project. These maps are free but 
copyright rests with the UN. The maps are validated by the National Mapping Agencies (NMA) of each UN Member State. 
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Instructions for loading shapefiles without using Excel: 

1. Copy your map shapefiles as explained above. 

2. Copy and paste the ID and Names column from the map.dbf file to replace the existing ones in the file data.csv 

3. Copy the ID column header name, and paste it under 'DBF-ID' in row 3/column 4 in the file data.csv. 

Note: The ID column may not contain spaces, symbols or numbers, and should have unique values only. 

 
GIS Shapefile Reader - Source Code 

The source code for reading the shapefiles is included in the directory SHPreader. It can be compiled to the file 
SHPreader.swf, which is read by StatPlanet. 

The code was written by Edwin van Rijkom under the LGPL license, with some additions by Andy Woodruff, and some 
slight modifications for use in StatPlanet. 

If you wish to change the names of the map files being read, you can change this in SHPreader.as, and publish it as 
SHPreader.swf through the file SHPreader.fla. 

For more information, see: http://shp.riaforge.org/ 

 


